NodeJS npm Error



  • Heyhoo,

    hat evtl. jemand ne Idee warum beim installieren der package.json folgende fehler auftreten?

    npm install
    npm http GET http://registry.npmjs.org/npm/2.7.4
    npm http GET http://registry.npmjs.org/express/4.12.3
    npm http GET http://registry.npmjs.org/socket.io/1.2.1
    npm http 304 http://registry.npmjs.org/express/4.12.3
    npm http 304 http://registry.npmjs.org/socket.io/1.2.1
    npm http 304 http://registry.npmjs.org/npm/2.7.4
    
    npm ERR! Unsupported
    npm ERR! Not compatible with your version of node/npm: express@4.12.3
    npm ERR! Required: {"node":">= 0.10.0"}
    npm ERR! Actual:   {"npm":"1.1.4","node":"0.6.12"}
    npm ERR!
    npm ERR! System Linux 3.2.0-23-generic
    npm ERR! command "node" "/usr/bin/npm" "install"
    npm ERR! cwd /var/www
    npm ERR! node -v v0.6.12
    npm ERR! npm -v 1.1.4
    npm ERR! code ENOTSUP
    npm ERR! message Unsupported
    npm ERR! errno {}
    npm ERR!
    npm ERR! Additional logging details can be found in:
    npm ERR!     /var/www/npm-debug.log
    npm not ok
    
    

    Alle Pakete sind in folgender package.json definiert:

    {
        "name": "",
        "version": "0.0.1",
        "main": "app.js",
        "dependencies": {
            "npm": "2.7.3",
            "express":"4.12.3",
            "socket.io": "1.3.5",
            "twig": "0.8.1"
        }
    }
    
    
    

    Danke im Voraus.!



  • Hallo Synic,

    der Fehler ist, dass du deine Express Version von Node/Npm installiert hast.
    Deine Version von Node ist 0.6.12 und es wird eine Mindestversion von 0.10.0 benötigt.
    Auch dein npm ist auf 0.6.12 während in deiner package.json eine version von 2.7.3 verlangt wird.

    Ich empfehle dir npm und Node upzugraden und es erneut zu versuchen.

    Windows:

    Node.js Website

    Linux:

    sudo apt-get install nodejs node npm



  • Problem wurde gelöst.
    Mir hatten einige python packages gefehlt.

    sudo apt-get update
    sudo apt-get install -y python-software-properties python g++ make
    sudo add-apt-repository ppa:chris-lea/node.js
    sudo apt-get update
    sudo apt-get install nodejs
    

    synic#



Es scheint als hättest du die Verbindung zu MyTechZone 2 verloren, bitte warte während wir versuchen sie wieder aufzubauen.